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 User Instructions for 
Twin Scan 88 

CAUTION: CAREFULLY READ INSTRUCTIONS BEFORE PROCEEDING. THE USER IS 
ASSUMED TO BE FAMILIAR WITH MICROSOFT WINDOWS AND PC OPERATION. 

OVERVIEW 
New Harley-Davidson® motorcycles use the SAE 

J1850 data bus for communications between the 
engine control module (ECM), instrument module (IM), 
turn signal/security module (TSM/TSSM), and 
diagnostic scan tools. The Twin Scan 88 is a low cost 
scan tool that is compatible with 2001-2006 H-D® fuel 
injected models using the Delphi® fuel injection system 
(including V-Rod®) and 2003-2006 carbureted models 
with new 12 pin ignition module. Please note that 
1999-2003 carbureted Twin Cam 88® models and all 
models with the earlier Marelli® fuel injection lack the 
J1850 data bus and are not compatible with the Twin 
Scan 88. 

The Twin Scan 88 connects to the four terminal 
Deutsch style data link connector on the H-D® wiring 
harness and requires a laptop PC for user interface 
and data display. You can read and clear diagnostic 
trouble codes from the ECM, TSM/TSSM,   
speedometer, and tach (on models with IM data bus). 
You can view real time engine data on an instrument 
panel type display. 

The Twin Scan 88 also features stand-alone 
data logging (no laptop PC attached). This feature 
provides diagnostic capabilities not found in any other 
available tools. The Twin Scan 88 is especially useful 
for diagnosing hard to find intermittent trouble codes. 
The motorcycle can be operated while the unit is 
installed. Under normal conditions (no trouble code), 
the unit can be set up to store data for the last hour of 
operation. If a trouble code is set, the unit automatically 
stops logging data 30 minutes after the code is set. 
Even days or weeks later, you can download the data. 
You can examine in detail what happened before and 
after the code was set. You have a range of 
capabilities for analyzing and printing out logged data 
that is displayed in a chart recorder format.  

The Twin Scan 88+ is an enhanced version that 
includes an input that can be connected to a Daytona 
Sensors WEGO II wide-band oxygen sensor interface. 
When the WEGO II is connected, the Twin Scan 88+ 
will log engine data along with the actual air/fuel ratio 
(AFR). The Twin Scan 88+ is an ideal tuning aid for 
use with the Screamin Eagle® Race Tuner (SERT) on 

fuel injected motorcycles. The software analyzes 
logged data and displays AFR and the required 
volumetric efficiency (VE) correction (in percent) with 
the same RPM rows and throttle position sensor (TPS) 
columns used in the SERT tables. 

Several sample data files are included in the 
program folder when Twin Scan software is installed: 

Sample1.log - Twin Scan 88 data from a fuel 
injected Twin Cam 88® application showing a 
trouble code being set 

Sample2.log & Sample3.log - Twin Scan 88+ 
data from a V-Rod® showing air/fuel ratio data 
logged from attached WEGO II 

Figure 1 – Twin Scan 88 

 
 

PC REQUIREMENTS 
The Twin Scan 88 has a female 9 pin D-sub 

connector that interfaces to an RS-232 serial port on 
the laptop PC. You will require a 9 pin male-to-female 
extension cable such as our P/N RS232-CBL-10. 
Similar cables are available from Belkin 
(www.belkin.com) as P/N F2N209-06-T or Office Depot 
as P/N 825851. You can also find the same type of 
cable at most office and computer supply stores.  
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Data transfer occurs at 56 kBaud. The high baud 
rate limits the maximum cable length and the use of an 
extension cable over 12 feet in length is not 
recommended. Due to the cable length limitation and 
the need for portable access, a laptop PC is 
recommended. The PC must have a free serial port 
(COM1-255) with a standard 9 pin male D-sub 
connector. If your laptop does not include a serial port, 
you can use a USB adapter. However, not all USB 
adapters will work correctly with the Twin Scan 88. 
Most of the inexpensive USB adapters are intended for 
interfacing Palm Pilot type devices and do not support 
the high baud rate required by our unit.  

We sell and recommend a low cost USB adapter 
(P/N USBG-232) that has been tested with a wide 
range of system configurations. The USBG-232 
adapter comes with correct and updated driver files on 
CDROM. After installation the USBG-232 adapter will 
usually appear as COM5. 

We recommend a laptop with Pentium processor 
and super VGA display (SVGA with 1024 x 768 pixel 
resolution) running Windows 98/ME/XP. Data chart 
display is graphics intensive and a high speed Pentium 
processor is recommended. Processors slower than 
300 MHz will exhibit sluggish program loading and 
response. The PC must have a CDROM drive for 
program loading. 

Twin Scan software includes print commands to 
print downloaded data. The program has been tested 
with Hewlett-Packard laser and inkjet printers and 
Epson inkjet printers. We recommend using a color 
inkjet printer. 

SOFTWARE INSTALLATION 
The software is supplied on CDROM media or in 

the form of a compressed file downloaded from our 
website. The installation process uses InstallShield. 
This industry standard installer is based the new 
Microsoft Windows Installer service that greatly 
reduces potential problems such as version conflicts 
and allows for application self-repair. Since Windows 
98 systems did not originally include the Windows 
Installer service, the required installer software is 
included in the distribution media.  

Before proceeding with installation, shutdown any 
other applications that may be running. Use the 
Windows Explorer or the Run command from the 
Windows Start Menu to launch setup.exe in the 
Twin_Scan folder on the CDROM or the setup.exe file 
downloaded from our website. InstallShield will install the 
software in an appropriate folder under Program Files. 

Once InstallShield has completed the 
installation, Twin Scan will appear on the Windows 
Start Menu. You can then launch it just as you would 
any other Windows program. Several sample data files 
are included in the program folder.   

Twin Scan software requires the Monospace 
821 BT fixed pitch printer font in order to properly align 
columns when printing. The Monospace 821 BT font is 
included in the distribution media and automatically 
copied to your Windows Fonts folder during 
installation. A backup copy is also placed in the 
program folder. If you accidentally delete this font, use 
the Install New Font command from the Fonts folder 
File menu. The filename associated with Monospace 
821 BT is monos.ttf. 

TWIN SCAN OPERATION  
The Twin Scan 88 connects to the four terminal 

Deutsch style data link connector on the H-D® wiring 
harness. In most cases, the data link connector is near 
the ECM (engine control module). Refer to the H-D® 
Electrical Diagnostic Manual for your model for 
connector location. Some models may have similar 
appearing connectors that could be mistaken for the 
correct data link connector.  

The Twin Scan 88 is powered through the data 
link connector whenever the ignition key is turned on. 
Please note that communication with the laptop PC is 
only possible when the ignition key is turned on.  

In general the engine does not have to be 
running to read and clear diagnostic codes. However, 
some custom wiring harnesses or wiring damage can 
lead to situations where the run/stop switch must be 
turned on to power up the various modules on the data 
bus.  

If the Twin Scan 88 is left connected, it will log 
data to internal memory whenever the ignition key is 
on, even if the engine is not running. This allows 
diagnosing conditions that cause the engine to stall. 
However, if the ignition key is inadvertently left on for 
an extended period of time, older data will be 
overwritten and lost.  

CAUTION: Twin Scan 88 units are not 
sealed against moisture damage. If the 
motorcycle is to be driven with the unit 
installed, it should be protected with a 
plastic bag. There is no warranty on 
units with moisture damage. 
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SOFTWARE OPERATION 
Connect the Twin Scan 88 to the data link 

connector on the motorcycle. Use an extension cable 
to connect the unit to a serial port on your laptop PC or 
USB adapter. Turn the ignition key on.  

After the Twin Scan program is launched, the 
main screen appears as shown below but without any 
data displayed. COM1 is used as the default port. If 
you connected the Twin Scan 88 unit to a different 
COM port, use the Port Setup command on the 
Communications menu. 

You can test communications between the Twin 
Scan 88 and the laptop PC by using the Read 
Firmware ID command on the Help menu (the ignition 
key must be on). If you get an error message, please 
refer to the Communications Troubleshooting 
Flowchart on page 12. 

DIAGNOSTIC TROUBLE CODES  
Use the View Diagnostic Trouble Codes 

command on the View menu. Click on the Read Codes 
button to display information for all available modules. 
As shown in Figure 2, the upper half of the screen 
displays the system ID and calibration code 
information. The lower half of the screen displays 
diagnostic trouble codes. Each current and historic 
trouble code is displayed along with a brief description. 
The software includes a database of all diagnostic 
trouble codes published by Harley-Davidson®. Please 
refer to the H-D® Electrical Diagnostic manual for 
your model for detailed explanations and 
troubleshooting flowcharts.  

 

 

 

Figure 2 – Diagnostic Trouble Code Display 
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You can print the displayed information to any 
Windows printer by clicking on the Print Codes button. 
You can use the Print Setup command on the File 
menu to select the printer.  

You can clear any codes by clicking on the Clear 
Codes button. 

TWIN SCAN SETUP  
Prior to using the real time engine data display 

or data logging features, you must set up the correct 
parameters. Use the Edit Twin Scan Parameters 
command from the Edit menu. A dialog box will appear 
as shown in Figure 3. You can select the type of 
engine control (carburetor or fuel injection) and the 
data logging interval. 

Selecting the Twin Scan 88+ option only affects 
real time display of air/fuel ratio (AFR) data. 
Irregardless of whether or not this option is selected, 
the Twin Scan 88+ will always log AFR data when a 
WEGO II is connected. If you mistakenly select this 
option for a standard Twin Scan 88, real time data 
display will fail with a timeout message. 

Figure 3 – Twin Scan Setup 

 
The Twin Scan 88 data buffer stores the last 

1600 data points. If you set the data logging interval to 
2.0 seconds, the unit will log about one hour of data. 
Data logging intervals of 0.5-2.0 seconds are suitable 
for on-road tests; a shorter interval of 0.25 seconds is 
recommended for dyno or shop tests. Once you have 
selected the appropriate parameters, click on the 
Upload to Twin Scan button.  

You can clear the data within the Twin Scan 88 
by using the Clear Twin Scan Data Buffer command 
from the Communications menu. If you change the 
data logging interval, you should also clear the Twin 
Scan 88 data buffer. 

REAL TIME ENGINE DATA DISPLAY 
You can display real time engine data by using 

the View Real Time Data command on the View menu. 
Real time engine data is displayed on an instrument 
panel type layout with round tach and speedometer 
gauges and bar graph type gauges for most other 
parameters. Barometric pressure, idle RPM and 
system status are displayed in additional boxes. If the 
engine is not running, most values will appear as zero. 
Figure 4 shows the parameters displayed for a fuel 
injection system. A subset of these parameters is 
displayed for a carburetor system. 

Displayed parameters include: 

RPM – engine crankshaft RPM (numeric value 
displayed beneath gauge) 

VSS – vehicle speed in MPH (numeric value 
displayed beneath gauge) 

BAT – battery voltage 

MAP – manifold pressure in In-Hg (29.92 In-Hg 
corresponds to sea level atmospheric pressure) 

TPS – throttle position (0 to 100%) 

FRONT ADV, REAR ADV – ignition advance in 
degrees BTDC 

FRONT INJ PW, REAR INJ PW – injector pulse 
width in milliseconds 

FRONT KNOCK, REAR KNOCK – knock retard 
value in degrees 

AFR –– if the Twin Scan 88+ option is selected 
for a fuel injection system, the air/fuel ratio bar 
graph has dual pointers as shown in Figure 4. 
The yellow pointer on the left side is the air/fuel 
ratio command (from the AFR table in the 
Delphi® system). The white pointer on the right 
side is the actual air/fuel ratio measured by the 
WEGO II. The legends CMD and WEGO serve 
as a reminder. Note that the WEGO value will 
remain near 10 until the sensor has warmed up. 
For other system configurations, only a single 
pointer is displayed and an appropriate legend 
identifies the data as either COMMAND or 
WEGO. 

IAC – idle air control stepper motor position 
(higher number means more idle air) 

ET – engine cylinder head temperature (deg C) 

IAT – intake air temperature (deg C) 
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BARO – barometric pressure in In-Hg (29.92 In-
Hg corresponds to sea level atmospheric 
pressure) 

IDLE RPM – this is the target value the system 
is attempting to maintain 

Additional status data is displayed in a box at 
the upper right of the screen. This data includes: 

ENGINE RUN – red if engine off/stalled, green if 
engine is running 

VTD ACTIVE – vehicle theft deterrent system 
active. Red if TSSM module present, otherwise 
green. Does not indicate if system is armed or 
tripped.  

VEHICLE TIP – red if vehicle tipped (excessive 
bank angle), otherwise green 

DTC SET – red if a diagnostic trouble code is 
set, otherwise green 

You can log data directly to the laptop PC while 
real time engine data display is active by clicking on 
the Start Data Logging button. Data is logged to a 
buffer memory that stores 1600 data points using the 
data logging interval you entered on the Twin Scan 
Setup dialog box. You can start and stop data logging 
as desired. The last 1600 data points will remain in the 
program data buffer. Please note that data logging to 
the buffer within the Twin Scan 88 is disabled 
during real time display. 

Figure 4 – Real Time Engine Data Display 
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BUFFER MEMORIES AND 
DOWNLOADING DATA  

There are two separate buffer memories: the 
scan tool data buffer (within the Twin Scan 88) and the 
program data buffer (in the laptop PC). 

When the Twin Scan 88 is operated in stand-
alone mode without a laptop PC attached, data is 
logged to its internal memory. This scan tool data 
buffer contains the last 1600 data points. You can 
download this data into the laptop PC using the 
Download Data from Scan Tool command on the 
Communications menu. You can clear the data within 
the Twin Scan 88 by using the Clear Twin Scan Data 
Buffer command from the Communications menu.  

The Twin Scan program running on the laptop 
PC also has a buffer memory. The program data buffer 
can obtain data from one of three sources: 

1. Data can be logged directly to the program data 
buffer in the laptop PC during display of real time 
engine data. Please note that data logging to the 
buffer within the Twin Scan 88 is disabled 
during real time display. 

2. Data can be downloaded from the Twin Scan 88. 
In this case, the data is transferred from the scan 
tool data buffer to the program data buffer.  

3. You can also open a previously saved file using 
the Open File command on the File menu. Data in 
the file is loaded into the program data buffer. 

Any existing data in the program data buffer is 
automatically cleared when you download data or open 
a file. You can also manually clear the program data 
buffer by using the Clear Program Data Buffer 
command from the Edit Menu. 

Regardless of the original source, the contents 
of the program data buffer can be saved to a file using 
the Save File command from the File menu. You can 
attach a comment or view an existing comment using 
the Edit Comment command from the Edit menu.  

Note that Twin Scan 88 data files use a .log 
extension. You should create a separate folder to store 
these files.      

DATA LOGGING CHART DISPLAY 
You can display the contents of the program 

data buffer on a chart recorder type screen by using 
the View Chart (Logged Data) command on the View 
menu. The last data logged will appear at the right 
end of the chart. Figure 5 shows the parameters 
displayed for a fuel injection system. A subset of these 
parameters is displayed for a carburetor system. 

Data parameters are the same as those listed 
on pages 4-5 for real time data display. An additional 
box at the lower right side of the screen shows the 
actual data logging interval in seconds. 

You can use the Maximum RPM command from 
the Edit menu to change the maximum RPM value 
displayed on the chart. 

You have a range of capabilities for analyzing 
the data displayed in the chart recorder format. You 
can select two parameters for display. Trace 1 is 
displayed in red with its Y axis legends on the left side 
of the chart. Trace 2 is displayed in green with its Y 
axis legends on the right side of the chart. 

The X axis is always elapsed time. You can 
select from one of three time scales. You can use the 
scroll bar to move the chart display window in terms of 
elapsed time. If you hold the left mouse button down 
within the chart area, a cursor line appears. The exact 
values of the parameters displayed on trace 1 and 
trace 2 and the elapsed time appear in windows above 
the chart. 

If you want to analyze the elapsed time between 
two events (for example the time required to accelerate 
from 0 to 60 MPH), you can move the cursor to the first 
event and then click on the Reset Time Display button. 
You can print the displayed chart to any Windows 
printer by clicking on the Print button (a color inkjet 
printer is recommended for best results).  
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Figure 5 – Data Logging Chart Display 
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AFR TABLE DISPLAY 
AFR (air/fuel ratio) table display is only 

applicable to Twin Scan 88+ units when operated with 
an attached WEGO II unit on a fuel injected 
motorcycle. In this mode of operation, the Twin Scan 
88+ is used as a data acquisition system to log AFR 
data measured by the WEGO II. A mating connector is 
provided on the Twin Scan 88+ for the 0-5 volt analog 
output of the WEGO II (white wire with Packard 
Weather Pack connector). Refer to the WEGO II 
instructions for installation and operation details. For 

best accuracy, the WEGO II black ground wire should 
be connected to the same frame ground as the H-D® 
data link connector. 

AFR data that has been logged can be analyzed 
and displayed by using the View AFR Table command 
on the View menu.  Figure 6 shows AFR display in 
VRSC (V-Rod™) format. You can select TC88 format 
for Twin Cam 88® applications. AFR data is displayed 
with the same RPM rows and throttle position sensor 
(TPS) columns used by the Screamin Eagle® Race 
Tuner (SERT).     

Figure 6 – AFR Display 
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Under Table Parameters, you can select: 

AFR Display – air/fuel ratio data as shown 
above 

VE Percent Correction Display  – required 
volumetric efficiency correction in percent, based on 
the target AFR value (normally 13.2 as recommended 
in the SERT manual when tuning with a wide-band 
exhaust gas oxygen sensor system) 

Target AFR – determines required percent VE 
correction. Any cells that differ at least 0.5 AFR from 
the target AFR value are shaded blue for rich or red for 
lean. 

Minimum Samples Per Cell – default value is 
5. Setting a higher value results in more accurate table 

values, but may result in fewer total cells with enough 
samples to appear in the table.  

Filter Unstable Data – when this option is 
selected, a data sample is only included if the 
preceding sample was also in the same cell. This 
option reduces errors during transients, but may 
prevent any data from being included during rapid 
acceleration.  

After you select a different table format or 
change table parameters, you must click on the 
Refresh Table button to display the revised table.     

Figure 7 shows VE percent correction display in 
VRSC (V-Rod™) format. You can click on the Print 
button to print out the table.  

 
Figure 7 – VE Percent Correction Display 
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You can analyze data from multiple files that you 
previously saved. If you want to add more data 
(perhaps logged under conditions that will yield 
coverage of additional cells), use the Open Additional 
File command from the File menu. The data will be 
analyzed and incorporated into the table. You can 
open an unlimited number of additional files. However, 
you cannot refresh the table format or parameters once 
you open an additional file. These selections will 
become grayed out. Also, you cannot save or view the 
original data once you open an additional file. Make 

sure you save any downloaded data before opening an 
additional file.  

To start a new analysis, you must exit from AFR 
Table Display and then use the Open File (or 
Download) command from the main menu.   

You can easily make the required corrections in 
the SERT Tuning Mode program by referring to the 
printed VE percent correction table and marking off 
cells as you edit them. Figure 8 shows a typical SERT 
VE table. 

Figure 8 – SERT VE Table 

 
 

For the SERT VE table, 2 units corresponds to 
one percent. You can start editing on a row, leave the 
mouse cursor on the increment box, and use the tab 
and/or arrow keys to navigate to successive cells. For 
each cell that requires a positive VE correction, right 
click the mouse as required (one click per percent). 

Mark off each cell on the printout after you correct it. 
Corrected cells will also appear shaded in the SERT 
program. After you have completed all the cells that 
require a positive correction, repeat the process for all 
the cells that require a negative correction (leave the 
mouse cursor on the decrement box).  
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SERT TUNING STEPS 
1. Start with the front cylinder (the choice is arbitrary). 

Install the WEGO sensor on the front exhaust pipe. 

2. In SERT Tuning Mode, set all values in the AFR 
table to the 13.2 target value, save your edited 
data to a file, and program the ECM. Note that the 
AFR target value of 13.2 is suggested in the SERT 
manual. However, you may want to use an AFR 
target value of 12.8 for a high performance engine. 

3. Use the Twin Scan 88+ system to log, download, 
and save several sets of data under varying 
conditions. Use a medium data logging interval 
(0.5 sec) for runs at steady speeds and a short 
interval (0.25 sec) for runs with rapid acceleration 
and transients.  

4. Analyze the data, print out the VE percent 
correction table, enter the required corrections in 
SERT Tuning Mode, save your edited data to a file, 
and program the ECM.  

5. Repeat steps 3 and 4 until no shaded cells 
(excessively rich or lean) appear in the VE percent 
correction table. Don’t worry about cells with a few 
percent error. If no shaded cells appear, everything 
is within ±0.5 AFR. This is about the expected 
accuracy of the Delphi® open loop speed-density 
system.    

6. Move the WEGO sensor to the opposite cylinder 
and repeat steps 3-5. 

7. In SERT Tuning Mode, set reasonable values in 
the AFR table, save your edited data to a file, and 
reprogram the ECM. 

 

 

 

 

 

IMPORTING DATA INTO EXCEL 
Data files saved from the Twin Scan program 

are in comma delimited ASCII format. You can easily 
import a data file into other programs such as Microsoft 
Excel for further analysis. You can also view data files 
with a text editor such as Windows WordPad. To 
import a data file into Excel: 

1. Start Excel. In the File Open dialog box, select 
Files of type: All Files (*.*). Then browse for the 
data file. 

2. The Text Import Wizard appears. For step 1, select 
delimited file type. For step 2, select comma 
delimiter. For step 3, select general column data 
format. Then click on Finish. 

3. You can then format the data and save the 
spreadsheet as an Excel file. 

COMMUNICATIONS 
TROUBLESHOOTING FLOWCHART 

Follow the communications troubleshooting 
flowchart shown on the next page. Experience has 
shown that most communication problems are 
motorcycle electrical system faults, user error, or PC 
compatibility issues. 
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Communications Troubleshooting Flowchart 
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