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 User Instructions for WEGO 4D  
Data Logging Software 

CAUTION: CAREFULLY READ INSTRUCTIONS BEFORE PROCEEDING. THE USER IS 
ASSUMED TO BE FAMILIAR WITH MICROSOFT WINDOWS AND PC OPERATION. 

OVERVIEW 
WEGO 4D Data Logging software (hereafter 

referred to as WEGO software) runs under Microsoft 
Windows ME/XP/Vista. This software allows users to 
download and display data logged by the WEGO IV 
dual channel unit. This version of WEGO software only 
supports the new WEGO IV dual channel units. It is not 
compatible with WEGO III or WEGO IV single channel 
units. Version 2.2 adds support for multiple fuel types 
and direct copy and paste of table data to Excel for 
easy transfer of correction values to Dynojet Power 
Commander software.   

After WEGO software is launched, the main 
screen appears blank. Data logged by the WEGO unit 
must be downloaded before it can be displayed, by 
using the Download Data From WEGO command on 
the Communications menu. Once data has been 
downloaded, it is automatically displayed on a chart 
recorder type screen. You can save this data by using 
the Save File command from the File menu. You can 
also display a previously saved data file by first using 
the Open File command on the File menu.  

A sample data file (Sample.log) for an actual 
road test is included in the program folder. 

PC REQUIREMENTS 
We recommend a laptop with Pentium processor 

and super VGA display (SVGA with 1024 x 768 pixel 
resolution) running Windows ME/XP/Vista. Data chart 
display is graphics intensive and a high speed Pentium 
processor is recommended. Processors slower than 
300 MHz will exhibit sluggish program loading and 
response. The PC must have a CDROM drive for 
program loading.  

WEGO software includes print commands to 
print downloaded data. The program has been tested 
with Hewlett-Packard laser and inkjet printers and 
Epson inkjet printers. We recommend using a color 
inkjet printer. 

The WEGO IV dual channel unit connects to 
your PC by means of a USB interface. A USB cable is 
supplied with the unit. The PC must have a free USB 

port. If you have an older PC without USB capability, 
you cannot use the unit. 

USB INSTALLATION 
WEGO IV dual channel units require installation 

of USB interface drivers. If you have already installed 
the USB interface drivers, you can skip this step. 

The WEGO IV USB interface is based on the 
FTDI FT232R chip and VCP (virtual COM port) drivers 
that allow the units to emulate a standard Windows 
RS-232 COM port. Updated Windows drivers, 
installation instructions and troubleshooting tips are 
available on the FTDI website at www.ftdichip.com. 
Additional information and troubleshooting tips can be 
found on the PC Link Tech FAQ on our website at 
www.daytona-sensors.com.  

A new USB driver that simplifies the installation 
process is available. This installs as an executable file, 
similar to other Windows programs. The Windows 
Found New Hardware Wizard will then detect the USB 
device when it is first connected and automatically 
install the correct driver without the user having to 
browse out to the CDROM. 

Before proceeding with installation, shutdown 
any other applications that may be running. For 
Windows Vista, you must disable the User Account 
Control (UAC) during installation. If you are not familiar 
with the UAC, please refer to the Vista UAC Tech Note 
on our website's PC Link Tech FAQ for details. 

1. Make sure your WEGO is not connected to your 
PC.  

2. Insert the Daytona Sensors CDROM. When the 
Daytona Sensors autorun menu appears, click on 
Software. Scroll down and click on the USB Driver 
link. When the File Download dialog box appears, 
click on "Run this program from its current 
location." Ignore any security warnings and click on 
Yes to continue.  

3. After installation of the driver is complete, connect 
the WEGO to the PC with the supplied USB cable. 
The Windows Found New Hardware Wizard will 
appear and complete installation of the USB 
drivers.   
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COM Port Configuration 
After completing the installation steps outlined 

above, you must configure the new COM port using 
Device Manager.  

1. Click Start, Settings, Control Panel, System, 
Hardware, and then Device Manager. Scroll down 
to Ports (COM and LPT).  

2. The unit will appear as a USB Serial Port. Click on 
this new port. 

3. Click on the Port Settings tab. 

4. Click on Advanced. In most cases the wizard will 
have installed your new unit as COM4 or COM5. 
For optimum performance, you should change the 
BM Options Latency Timer to 2 msec as shown in 
Figure 1. 

5. Once you have configured a COM port number for 
your new unit, make sure that you use this same 
COM port selection in the WEGO software by 
using the Port Setup command from the 
Communications menu. 

Figure 1 – COM Port Configuration 

 

SOFTWARE INSTALLATION 
The software is supplied on CDROM media or in 

the form of a compressed file downloaded from our 
website. The installation process uses InstallShield. 
This industry standard installer is based the new 
Microsoft Windows Installer service that greatly 
reduces potential problems such as version conflicts 
and allows for application self-repair.  

Before proceeding with installation, shutdown any 
other applications that may be running. For Windows 
Vista, you must disable the User Account Control 
(UAC) during installation. If you are not familiar with the 
UAC, please refer to the Vista UAC Tech Note on our 
website's Tech FAQ for details. 

Use the Windows Explorer or the Run command 
from the Windows Start Menu to launch setup.exe in the 
WEGO4D_Log folder on the CDROM or the setup.exe 
file downloaded from our website. InstallShield will install 
the software in an appropriate folder under Program 
Files. Once InstallShield has completed the installation, 
WEGO 4D Data Logging will appear on the Windows 
Start Menu. You can then launch it just as you would 
any other Windows program.  

WEGO software requires the Monospace 821 
BT fixed pitch printer font in order to properly align 
columns when printing. The Monospace 821 BT font is 
included in the distribution media and automatically 
copied to your Windows Fonts folder during 
installation. A backup copy is also placed in the 
program folder. If you accidentally delete this font, use 
the Install New Font command from the Fonts folder 
File menu. The filename associated with Monospace 
821 BT is monos.ttf. 

WEGO CONNECTION  
The WEGO IV dual channel unit connects to 

your PC by means of a USB interface. A USB cable is 
supplied with the unit. Turn on power to the WEGO 
unit. We recommend that you do not run the engine 
while you are downloading data. 

WEGO SETUP  
Prior to using the WEGO, you must set up the 

data logging parameters. Use the Edit WEGO 
Parameters command from the Edit menu. A dialog 
box will appear as shown in Figure 2. You can set the 
data logging interval and RPM pulses per revolution 
and additional parameters.. 

The WEGO data buffer stores the last 12000 
data points. If you set the data logging interval to 0.50 
seconds, the unit will log 100 minutes of data. Data 
logging intervals of 0.2-1.0 seconds are suitable for on-
road tests; a shorter interval of 0.10 seconds is 
recommended for dyno tuning. You can clear the data 
within the WEGO by using the Clear WEGO Data 
Buffer command from the Communications menu. If 
you change the data logging interval, you should also 
clear the WEGO data buffer. 
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Figure 2 – WEGO Setup 

 
If you are logging engine RPM, you must set the 

correct value for RPM pulses per revolution (PPR). 
Some general guidelines follow, based on what type of 
signal you have connected to the WEGO brown wire: 

Tach signal. In most cases PPR= N/2 where N is 
the number of cylinders. For example a V-twin 
motorcycle engine would require PPR=1and a V8 
automotive engine would require PPR=4 

Harley-Davidson dual fire ignition with 
connection to Coil- terminal. Use PPR=1 

Harley-Davidson single fire ignition with 
connection to either Coil- terminal. Use PPR=0.5 

Distributor type ignition with connection to Coil- 
terminal. Same as for a tach signal. Use PPR= N/2 
where N is the number of cylinders. 

Wasted spark coil pack (distributorless system) 
with connection to Coil- terminal. Use PPR=1. 

Coil on plug (no wasted spark) with connection to 
Coil- terminal. Use PPR=0.5 

Capacitive Discharge (CD) ignition using tach 
adapter. For one cylinder engines, use PPR=1 

RPM Debounce  – RPM signal filtering in 
milliseconds (msec). Use the default value of 0.50 
msec for most applications. Ford 4.6L modular V8 
engines will require a value of 3.5 msec. Suzuki 
Hayabusa models will require a value of 3.0 msec. 
If the RPM trace appears noisy, try a higher RPM 
debounce value.  

Minimum LED Brightness - This parameter sets 
the minimum LED brightness under low light (night) 
conditions. A value of 5% is reasonable for most 
applications. 100% represents maximum 
brightness. 

After you have entered the correct parameters, 
you must upload them to the WEGO unit. Please note 

that clicking on Restore Defaults only displays default 
values and does not affect the WEGO unless you then 
upload the restored values.   

Please note that the WEGO only logs data when 
the heater elements in the sensors have warmed up to 
normal operating temperature. If you use WEGO 
software to communicate with the WEGO (i.e. upload 
parameters or download data), data logging stops. The 
display on the WEGO will also show "PC." You must 
cycle power to the WEGO off and on again before data 
logging will resume. 

DATA LOGGING CHART DISPLAY 
Data logged by the WEGO unit is displayed on a 

chart recorder type screen. Data logged by the WEGO 
unit must be downloaded before it can be displayed, by 
using the Download Data From WEGO command on 
the Communications menu. Once data has been 
downloaded, it is automatically displayed. The last 
data logged will appear at the right end of the 
chart.  You can save this data by using the Save File 
command from the File menu. You can display a 
previously saved data file by first using the Open File 
command on the File menu. Note that WEGO data files 
use a .log extension. You should create a separate 
folder to store these files.  

You have a range of capabilities for analyzing 
downloaded data displayed in the chart recorder 
format. You can select two parameters for display. 
Trace 1 is displayed in red with its Y axis legends on 
the left side of the chart. Trace 2 is displayed in green 
with its Y axis legends on the right side of the chart. 

The X axis is always elapsed time. You can 
select from one of four time scales. You can use the 
scroll bar to move the chart display window in terms of 
elapsed time. If you hold the left mouse button down 
within the chart area, a cursor line appears. The exact 
values of the parameters displayed on trace 1 and 
trace 2 and the elapsed time appear in windows above 
the chart. 

If you want to analyze the elapsed time between 
two events, you can move the cursor to the first event 
and then click on the Reset Time Display button. You 
can print the displayed chart to any Windows printer by 
clicking on the Print button (a color inkjet printer is 
recommended for best results).   
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Figure 3 – Data Logging Chart Display 

 

 
Data parameters include: 

RPM – engine crankshaft RPM 

SENSOR 1 AFR and SENSOR 2 AFR – air/fuel 
ratio (10:1 to 20:1 for gasoline)  

ANALOG INPUT – analog signal input that can 
be scaled and displayed in user selected units 
(as explained further on). 

You can use the Maximum RPM command from 
the Edit menu to change the maximum RPM value 
displayed on the chart. 

Additional data is displayed at the lower right 
side of the screen. This data includes: 

Diagnostic Code – normally blank unless a 
diagnostic code is set. Diagnostic codes include 

battery low, battery high, sensor open, sensor 
short, and over temperature. Over temperature 
means that the WEGO unit (not the sensors) 
has become too hot. 

Stoichiometric Ratio - displayed for selected 
fuel type (refer to Fuel Type section for details) 

Log Interval – the actual data logging interval in 
seconds 

The data logging interval is displayed at the 
lower right side of the screen. The WEGO data buffer 
stores the last 12000 samples. You can clear the data 
within the WEGO by using the Clear WEGO Data 
Buffer command from the Communications menu. If 
you change the data logging interval, you should also 
clear the WEGO data buffer. 
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Please note that the WEGO only logs data when 
the heater element in the sensor has warmed up to 
normal operating temperature. If you use WEGO 
software to communicate with the WEGO (i.e. upload 
parameters or download data), data logging stops. The 
display on the WEGO will also show "PC." You must 
cycle power to the WEGO off and on again before data 
logging will resume. 

ANALOG INPUT SCALING 
When a chart display is active, you can use the 

Analog Input Scaling command on the Edit menu to 
setup the scaling and units display for the analog input.  

In general, you will enter the minimum and 
maximum input voltages and corresponding scaled 
values displayed on the chart along with the desired 
chart legend. The minimum and maximum voltages 
must be in the range of 0.0-5.0 volts. The scaled 
values must be in the range of 0-10,000.  

Once entered, analog input scaling values 
are saved with the data. The program also 
remembers the last analog input scaling values. If 
you use the WEGO for multiple vehicle 
applications, always verify that the analog input 
scaling is correct for any new data that you 
download. Clicking on Restore Defaults causes the 
program to revert to direct 0.0-5.0 volt display on the 
chart.  

Figure 4 shows settings for a typical throttle 
position sensor (TPS), with 0.4 volts corresponding to 
0% and 4.5 volts corresponding to 100%. 

Figures 5 and 6 show settings for standard 
GM/Delphi 1 bar and 2 bar manifold pressure (MAP) 
sensors. Most GM vehicles and all Harley-Davidson® 
motorcycles with Twin-Cam 88® engines use GM 1 bar 
type MAP sensors. GM 2 bar MAP sensors are often 
used with aftermarket engine controls for 
turbo/supercharger applications. 

For other types of sensors, we suggest that you 
check the sensor output waveform with a scope meter. 
Verify that the sensor output is an analog voltage 
within the 0.0-5.0 volt range. Some Ford MAP sensors 
and GM mass airflow (MAF) sensors use a frequency 
output that is not compatible with the WEGO analog 
input. Once you verify that the sensor has an analog 
output, you still have to determine the output scaling. 
You may find this information in the service manual or 
you may have to do some reverse engineering with a 
scan tool. Additional information is available on the 
WEGO Tech FAQ at www.daytona-sensors.com. 

 

Figure 4 – Input Scaling for Typical TPS 

 

Figure 5 – Input Scaling for GM 1 Bar MAP 

 
Figure 6 – Input Scaling for GM 2 Bar MAP 
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FUEL TYPE 
When a chart display is active, you can use the 

Fuel Type command on the Edit menu to setup the 
scaling of AFR values for gasoline, methanol, ethanol, 
or a user defined fuel type. All WEGO units will log 
data correctly for any selected fuel. However, only 
standard gasoline fuel (or methanol for special WEGO 
"M" units) will show the correct AFR values on the 
WEGO display.  

Once entered, the fuel type (and 
corresponding stoichiometric ratio) is saved with 
the data. The program also remembers the last fuel 
type. If you use the WEGO for multiple vehicle 
applications, always verify that the fuel type is 
correct for any new data that you download. 

Figure 7 – Fuel Type Selection 

 
 

 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 

AFR TABLE DISPLAY 
AFR (air/fuel ratio) table display is only possible 

when both engine RPM and correctly scaled throttle 
position sensor (TPS) data has been logged from a 
fuel injected vehicle. TPS data must be correctly 
scaled from zero to 100%. Refer to Analog Input 
Scaling section on page 5. Please note the AFR table 
display is currently available only for gasoline fuel.  

AFR data that has been logged can be analyzed 
and displayed by using the View AFR Table command 
on the View menu. The table format is intended to 
match the RPM rows and TPS columns used by 
Dynojet Power Commander (PC) systems. The screen 
snapshot in Figure 8 shows AFR data display. 

Under Table Data, you can select Sensor 1 or 
Sensor 2 AFR. Under Table Parameters, you can 
select: 

AFR Display – air/fuel ratio sensor data (as 
shown above). Any cells that differ at least 0.5 AFR 
from the target AFR value are shaded blue for rich or 
red for lean.  

Fuel Percent Correction Display  – required 
fuel correction in percent, based on the target AFR 
value. Any cells that differ at least 0.5 AFR from the 
target AFR value are shaded blue for rich or red for 
lean. 

Target AFR – target value used to determine 
required percent fuel correction.   

Minimum Samples Per Cell – default value is 
5. Setting a lower higher value results in more accurate 
table values, but may result in fewer total cells with 
enough samples to appear in the table. If you have 
limited data (such as a single file) try using a lower 
value. More cells will appear. 

Filter Unstable Data – when this option is 
selected, a data sample is only included if the 
preceding sample was also in the same cell. This 
option reduces errors during transients, but may 
prevent any data from being included during rapid 
acceleration.  

After change the table parameters, you must 
click on the Refresh Table button to display the revised 
table.  
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   Figure 8 – AFR Display 

 
 
 

The screen snapshot in Figure 9 shows fuel 
percent correction display. You can click on the Print 
button to print out the table.  

You can analyze data from multiple files that you 
previously saved. If you want to add more data 
(perhaps logged under conditions that will yield 
coverage of additional cells), use the Open Additional 
File command from the File menu. The data will be 
analyzed and incorporated into the table. You can 
open an unlimited number of additional files. However, 

you cannot refresh the table parameters once you 
open an additional file. These selections will become 
grayed out. Also, you cannot save or view the original 
data once you open an additional file. Make sure you 
save any downloaded data before opening an 
additional file.  

To start a new analysis, you must exit from AFR 
Table Display and then use the Open File (or 
Download) command from the main menu.   
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Figure 9 – Fuel Correction Display 

 
 

POWER COMMANDER TUNING 
RECOMMENDATIONS 

 You can use two approaches to make the 
required corrections in the Power Commander (PC) 
program. If you have Microsoft Office with Excel, you 
can directly copy and paste data from the WEGO Log 
software to an Excel spreadsheet and then copy and 
paste from the Excel spreadsheet into the PC program. 
In the WEGO Log software, you can select a range of 
cells with the mouse and right click to bring up a copy 
menu. You can also left click on the upper left legend 
cell to select the entire table and then right click to 
bring up the copy menu. For more details on using 
Excel, including sample spreadsheets, please visit the 
WEGO Tec FAQ on our website at www.daytona-
sensors.com.     

Alternately, you can manually enter the required 
corrections in the PC software by applying the printed 
fuel percent corrections calculated by the WEGO Log 
software to the PC fuel table. You are adding the 
calculated fuel percent correction values from the 

WEGO Log software to the PC fuel table. You can 
mark off cells as you edit them. Figure 10 shows a 
typical PC fuel table. 

Power Commander Tuning Steps 
1. Install the WEGO system. Refer to the WEGO 

installation instructions for tach and TPS signal 
hookup. Access to a shop manual with electrical 
diagrams for your vehicle is highly recommended. 
Verify that the TPS signal is correctly scaled. Refer 
to the Analog Input Scaling section on page 5. 
Verify that the RPM and TPS values are correctly 
displayed in data logging chart display. The legend 
text must contain TPS% exactly as shown in 
Figure 4, otherwise an error message will appear 
when you try to use the AFR table display feature. 

2. Start with an available Power Commander (PC) 
map that most closely matches your application.  

3. Use the WEGO system to log, download, and save 
several sets of data under varying conditions. Use 
a medium data logging interval (0.5 sec) for runs at 
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steady speeds and a short interval (0.10 sec) for 
runs with rapid acceleration and transients 
including dyno tests.  

4. Data in decel areas (low 0-2% TPS above idle 
RPM) should be regarded with caution as exhaust 
reversion effects may cause errors. Unless you are 
experiencing a significant problem during decel, we 
suggest that you ignore these cells.  

5. Analyze the data, enter the required corrections in 
the PC map, save your edited map to a file, and 
send the map to the PC.   

6. Repeat steps 3-5 until no shaded cells (excessively 
rich or lean) appear in the fuel percent correction 
table. Don’t worry about cells with a few percent 
error or minor imbalance between cylinders.  

Figure 10 – Power Commander Fuel Table 
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IMPORTING DATA INTO EXCEL 
Data files saved from WEGO software are in 

comma delimited ASCII format. You can easily import 
a data file into other programs such as Microsoft Excel 
for further analysis. You can also view data files with a 
text editor such as Windows WordPad. To import a 
data file into Excel: 

1. Start Excel. In the File Open dialog box, select 
Files of type: All Files (*.*). Then browse for the 
data file. 

2. The Text Import Wizard appears. For step 1, select 
delimited file type. For step 2, select comma 
delimiter. For step 3, select general column data 
format. Then click on Finish. 

3. You can then format the data and save the 
spreadsheet as an Excel file. 

AFR data is saved as gasoline AFR values (with 
stoichiometric ratio 14.69) regardless of fuel type 
setting. To convert to other fuel types, use the formula: 

AFR_Fuel = (Stoichiometric_Ratio_Fuel  x 
AFR)/14.69  

To convert to Lambda units, use the formula: 

Lambda = AFR/14.69 

TROUBLESHOOTING FLOWCHART 
Follow the troubleshooting flowchart shown 

below. Experience has shown that most 
communication problems are user error or PC 
compatibility issues. 

 

Troubleshooting Flowchart 
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